Resource not found for the segment – Power Automate

Hi Everyone,

Today I was working with Power Automate and the requirement was simple on the update of the case status, we have to create an entry in the Custom activity entity. Obviously, this is simple and we don’t want this operation to be synchronous, hence we have chosen to do it using a Flow.

After starting working on Flows for this requirement, I understand the real meaning of “Simple to understand but difficult to master.” The reason behind this statement was the flow we have written as below was not working and failing showing an error message as “Resource not found for the segment…”.

Here is the Create Record I have configured.

After quick check, came to know that issue was with the way of referencing attributes. We have to pass lookup values in “Odata Id” format as below

EntityNameInPlural(Record’sId/GUID)

In my scenario, for case lookup I have given as /incidents/(GUID) and it started working.

Hope this helps.


Happy 365’ing
Gopinath

One thought on “Resource not found for the segment – Power Automate

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s