The Solution ID is incorrect or missing. Add the correct Solution ID to the URL and try again – Dynamics 365 CE

Hi Everyone,

Today I was getting the below issue when I tried to edit Model Driven App in Make.PowerApps.com (New UI for Solutions) and it is working absolutely fine in Classic Editor.

“The Solution ID is incorrect or missing. Add the correct Solution ID to the URL and try again.”

However, to understand more on this, raised a support ticket with Microsoft and continued with my R & D. After spending sometime, found that there is an issue with the URL it is trying to open.

http://ORGName.crm.dynamics.com/designer/app/00000001-0000-0000-0001-00000000009b/7bc7968c-7ef1-e825-a845-00044a2b29f8

The solution Id is considered as 00000001-0000-0000-0001-00000000009b instead of the Solution ID in which component exists.

This is the URL of the Model Driven App when I opened it from Classic UI.

https://orgname.crm.dynamics.com/designer/app/50ABCDEF-6496-E811-A837-000D3A27889D/ABCDEF-7EF1-E811-A845-ABCDEF2B29F8

By the time we analyse this, got a response from Microsoft saying this issue might be due to the missing of “Common Data Service Default Solution” in the environment and they are actively working on the fix and also trying to understand the root cause of it. For now, they have asked to continue with the Classic Editor as a work around.

Hope this helps.


Happy 365’ing
Gopinath.

One thought on “The Solution ID is incorrect or missing. Add the correct Solution ID to the URL and try again – Dynamics 365 CE

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s